Help Center/Details/

Get Start

This guide is intented for publishers who want to monetize a Unity app with Pangle.
For now Pangle Unity Plugin supports the following ad formats: Rewarded Video, Interstitial Video, Banner

Integrating the Pangle Unity plugin into an app, which you will do here, is the first step toward displaying Pangle ads and earning revenue. Once the integration is complete, you can choose an ad format to get detailed implementation steps.

Prerequisites

  • Use Unity 2019 or higher
  • To deploy to iOS
    • Xcode 11 or higher
    • IOS 10.X and higher
    • Supporting architecture: x86-64, armv7, arm64, i386
    • CocoaPods
  • To deploy to Android
    • MinSdkVersion 14 and higher
    • TargetSDKVersion 28 and higher
    • CompileSdkVersion 29 and higher
    • GradleVersion required 4.1.0 and higher

Note:
1、The official demo example is the demonstration process using the unity2019 version. If you use the unity2018 version for access, make sure to import the PangleAdapterScripts.unitypackage and Example.unitypackage(example files) in the Unity editor, and then delete the Packages folder. The system will automatically generate new Packages.
2、If you use unity2018 version View ad sample style can not see, you can replace 2018DemoUI_CN.unitypackage file for viewing, you can reach out to Pangle support team for the file via email pangle_support@bytedance.com

Download the Pangle Unity plugin

The Pangle Unity plugin enables Unity developers to easily serve Google Mobile Ads on Android and iOS apps without having to write Java or Objective-C code. The plugin provides a C# interface for requesting ads that is used by C# scripts in your Unity project.
Download Pangle Unity plugin on Pangle platform.

截屏2021-09-08 下午11.35.41.png

Import Unity Plugin to your project

Open your project in the Unity editor, select Assets > Import Package > Custom Package, and find the PangleAdapterScripts.unitypackage. Make sure all files are selected, and then click Import.

fa4e76c2-3cf6-4744-8368-56fc9781f422.png

Automatically upgrade SDK version configuration

Open your project in the Unity editor and select Pangle->Manage SDKs->Upgrade to upgrade the version, see screenshot for details
pangle_manage.png
for details

Notice:

  1. Upgrade button should be disabled if there is no newer version.
    Pangle.png
  2. [Strongly recommended]
    After the SDK version is automatically upgraded, DELETE following config string in OTHER_LDFLAGS from *.debug.xcconfig and *.release.xcconfig. (Also apply if there are any other build xcconfig file exist)
    -framework "BUAdSDK" -framework "BUFoundation" -framework "BUVAAuxiliary"
    
    iOS自动升级补充.png
  3. In addition, we no longer provides PangleSDK.unitypackage after version 3700, Instead, PangleSDK is managed by CocoaPods install CocoaPods.
Did the content solve your problem?