logo

Update your Pangle SDK to v3.3.6.2 for iOS 14 Compatibility

Ensuring a seamless monetization experience for our publishers is Pangle's top priority. We've recently updated the Pangle iOS SDK to version 3.3.6.2 in accordance with Apple's AppTrackingTransparency (ATT) framework. We'd highly recommend you update your iOS SDK to version 3.3.6.2 or above before the ATT framework takes effect in order to avoid potential operation issues or revenue loss.

In a nutshell, here is what developers need to do:

  • Update to Pangle iOS SDK v3.3.6.2 as soon as possible. The iOS 14 compatible SDK versions are also available on our mediation partners' websites including ironSource, MAX, and MoPub.


  • Add the following Pangle SKAdNetwork IDs to your app's Info.plist file and include IDs for all of your ad networks.

JavaScript

1 <key>SKAdNetworkItems</key>
2   <array>
3     <dict>
4       <key>SKAdNetworkIdentifier</key>
5       <string>238da6jt44.skadnetwork</string>
6     </dict>
7     <dict>
8       <key>SKAdNetworkIdentifier</key>
9       <string>22mmun2rn5.skadnetwork</string>
10     </dict>
11   </array>

切换主题复制
  • Follow the guidelines on Apple's Documentation page to ensure your app supports Apple's ATT framework and is thus able to access IDFA.


Read the iOS 14 actions article on our Support page for details and sample code. Pangle is dedicated to providing you with the best possible solutions in the post-IDFA era. Please stay tuned for more updates.